Hello, World!

After installing GameFlow, let’s do a quick sanity check to make sure GameFlow is working properly. For that, we will build a simple Hello, World! project.

Assuming GameFlow has been installed into your project, you should see a Tools menu with GameFlow as a sub-menu. Select Tools > GameFlow > About and you should see the credits of the fine folk that worked to bring you GameFlow.

Once you have verified the menu is present, go to the GameObject menu. Select GameObject > 3D Object > Cube. You should now see a simple white Cube in the center of your project.

Cube with nothing else

Click Add Component in the Inspector, and search for the GameFlow component. Double-click to add it to your Cube.

Adding GameFlow

Now that you have a GameFlow component attached to your Cube, click the [+] button to add a block.

Double-click on the On Start program block (the first one under Frequently Used).

Adding a Block

Now that you have an On Start block, you’ll next add Log Message Action.

Click on the [+] button inside of the On Start block.

Two plus buttons right next to each other might seem confusing at first! The bottom [+] will add another Program, the [+] inside the On Start block will add an Action to perform when OnStart is called. After experimenting with GameFlow for a while you’ll get the hang of it.

Adding an Action

Once you have added the Log Message Action, all you have to do is pick a logging level and a message - here, we are using the industry standard “Hello, World!” message, but feel free to get creative.

Once you are done setting up your log message, go to the Game view and click Play. Open the Console window and you should see your message!

Viewing the message

If all of this is working - congratulations, you’ve written your first GameFlow program!